Thread (8 messages) flat view 8 messages, 3 authors, 2016-08-11

Re: [PATCH 2/4] Rename remote_only to display_mode

From: Andy Parkins <hidden>
Date: 2016-08-11 20:15:52

Possibly related (same subject, not in this thread)

On Friday 2006 November 03 02:40, Junio C Hamano wrote:
If you make this a "mode", it probably is better to make 1 and 0
into symbolic constants.  This patch taken alone is regression
in readability.
In my own code I would have done exactly that; however I've been trying to 
keep my patches as minimal as possible.

Digressing a little: what is the polite form of patches for git?  My strategy 
with this set was to make each patch as small as possible to reach my end 
point.  If those patches were okayed on the list, I could then do a "make 
more beautiful" patch, which is really nothing to do with the original 
changes to functionality but would make the code prettier.  Really I'm asking 
what level of intrusiveness of patch is not considered rude?  In making my 
patches, should I ride rough-shod over current implementation and just do it 
how I'd do it or should I try to fit in (as I did in this case)?
Something like this untested patch, that is...
I'm very much in favour; I shall make changes of this form soon.


Andy

-- 
Dr Andy Parkins, M Eng (hons), MIEE
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help