Johannes Schindelin [off-list ref] writes:
quoted
quoted
quoted
merge = pu for remote second # merge 'pu' if pulling from second
I actually am in favor of Johannes's one, except that it does
look like you are always making a pentapus merge of pu, for,
remote and second branches into xyz ;-).
Would
merge = pu, when pulling second
be better? ;-)
The users can work it around by writing:
merge pu remote second for
Just document it clearly and say "if you are going to make an
pentapus (or more) with remote branches that include ones named
'for' and 'remote', do not place them as third and second
(respectively) word from the end on the line" ;-).
Your "noise word" remote is actually useful.