On Mon, 11 Dec 2006 17:11:24 -0800
Junio C Hamano [off-list ref] wrote:
quoted
As Junio already highlighted, the "branch.*" namespace is for actual
branch names. This config option should go into "color.branch" or some
other spot.
I didn't. And "branch.color = auto" is actually fine.
The problematic case is "branch.color.remote = purple".
Technically it is workable.. but why even start down the road of having
anything but branch names after a "branch."? There has to be a better
spot for this variable, and it makes it more future proof, as you
highlighted.