Thread (1 message) 1 message, 1 author, 2016-06-16

Re: [PATCH] pathspec: rename free_pathspec() to clear_pathspec()

From: Junio C Hamano <hidden>
Date: 2016-06-16 02:19:42

Jeff King [off-list ref] writes:
I think diff_filespec_clear() would not be quite right. It is freeing
only the allocated _data_, but leaving the other portions intact.
You are (as usual) more right than I am ;-)

Yes, the free_data() is designed to retain enough information about
the filespec so that the data can be re-read by the next person who
needs to access it after free_data() is called; i.e. it was a
measure to reduce the memory pressure by trading it off with I/O
cost.  It is wrong to name it "clear", which is to "clear the slate,
make it into pristine state" whose side effect is to release held
resources.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help