Re: [PATCH v3 05/13] worktree.c: mark current worktree
flat view
From: Duy Nguyen <hidden>
Date: 2016-06-16 02:19:18
On Wed, May 11, 2016 at 6:03 AM, Junio C Hamano [off-list ref] wrote:
Duy Nguyen [off-list ref] writes:quoted
On second thought, why hold patches back, lengthen the worktree-move series and make it a pain to review? I moved a few patches from worktree-move into this series and I took two other out to create nd/error-errno. So I'm going to take more patches out of it, creating two bite-sized series, to be sent shortly. The first one is purely cleanup (ok, 1/7 is not exactly cleanup) [1/7] completion: support git-worktree [2/7] worktree.c: rewrite mark_current_worktree() to avoid [3/7] git-worktree.txt: keep subcommand listing in alphabetical [4/7] worktree.c: use is_dot_or_dotdot() [5/7] worktree.c: add clear_worktree() [6/7] worktree: avoid 0{40}, too many zeroes, hard to read [7/7] worktree: simplify prefixing pathsWhere are these patches designed to apply? It appears that this depends on something in 'next' (probably nd/worktree-various-heads topic?)
Yes. Sorry I forgot to mention that. Though if you move 2/7 to nd/worktree-various-heads (and deal with some conflicts in worktree.c) then it may become independent. -- Duy