From: Eric Sunshine <hidden> Date: 2016-06-16 02:19:17
On Tue, May 10, 2016 at 3:48 PM, Eric Sunshine [off-list ref] wrote:
Actually, I think we can have improved encapsulation and maintain
readability like this:
case "$1" in
...
-g) env="$2"; shift; shift ;;
...
esac
...
test_expect_success "..." '
if test -n "$env"
do
test_when_finished "unset GIT_DIR"
GIT_DIR="$env"
export GIT_DIR
fi
...
'
At this point, I'd also rename 'env' to 'gitdir' to be more meaningful.