On Mon, May 2, 2016 at 10:40 AM, Junio C Hamano [off-list ref] wrote:
"Keller, Jacob E" [off-list ref] writes:
quoted
True. I think the chances that it needs such a thing are quite minor,
and if an undocumented knob gets exposed it would have to become
documented and maintained, so I'd prefer to avoid it. Given that the
risk is pretty small I think that's ok.
OK, then let's do only the "documentation" part.
The patch below looks good to me.
Thanks,
Stefan
quoted hunk ↗ jump to hunk
-- >8 --
Subject: [PATCH] diff: undocument the compaction heuristic knobs for experimentation
It seems that people around here are all happy with the updated
heuristics used to decide where the hunks are separated. Let's keep
that as the default. Even though we do not expect too much trouble
from the difference between the old and the new algorithms, just in
case let's leave the implementation of the knobs to turn it off for
emergencies. There is no longer need for documenting them, though.
Signed-off-by: Junio C Hamano <redacted>
---
Documentation/diff-config.txt | 5 -----
Documentation/diff-options.txt | 6 ------
2 files changed, 11 deletions(-)
diff --git a/Documentation/diff-config.txt b/Documentation/diff-config.txt
index 9bf3e92..6eaa452 100644
--- a/Documentation/diff-config.txt
+++ b/Documentation/diff-config.txt
@@ -166,11 +166,6 @@ diff.tool::
include::mergetools-diff.txt[]
-diff.compactionHeuristic::
- Set this option to enable an experimental heuristic that
- shifts the hunk boundary in an attempt to make the resulting
- patch easier to read.
-
diff.algorithm::
Choose a diff algorithm. The variants are as follows:
+diff --git a/Documentation/diff-options.txt b/Documentation/diff-options.txt
index b513023..3ad6404 100644
--- a/Documentation/diff-options.txt
+++ b/Documentation/diff-options.txt
@@ -63,12 +63,6 @@ ifndef::git-format-patch[]
Synonym for `-p --raw`.
endif::git-format-patch[]
---compaction-heuristic::
---no-compaction-heuristic::
- These are to help debugging and tuning an experimental
- heuristic that shifts the hunk boundary in an attempt to
- make the resulting patch easier to read.
-
--minimal::
Spend extra time to make sure the smallest possible
diff is produced.
--2.8.2-458-gacc1066