Jeff King [off-list ref] writes:
On Wed, Mar 30, 2016 at 02:07:14PM -0700, Junio C Hamano wrote:
quoted
This is a tangent, but am I the only one who finds that the naming
of functions in config-get API is confusing? Just wondering if we
should rename the ones that keeps the memory ownership to the config
subsystem with s/get/peek/ or something.
You are definitely not the only one.
I think the get/peek thing would help, but I also get confused between
git_config_string() and git_config_get_string().
I actually do not have problems with the ones with names that do not
have "get" in.
git_config_$type() is always a helper function that are designed to
be called by config callback to parse (and complain) a <var, val>
pair that is expected to be of $type, and git_$family_config() is
always a helper function that are designed to be used as the
callback of git_config() to handle the configuration related to the
named command family.