From: Jacob Keller <redacted>
Since 2.4, apache will fail to load unless mod_unixd is loaded in order
to drop privileges.
Signed-off-by: Jacob Keller <redacted>
---
I am not sure why this wasn't there already, but I am unable to run
httpd 2.4.18 without it, on Fedora 23.
t/lib-httpd/apache.conf | 3 +++
1 file changed, 3 insertions(+)
diff --git a/t/lib-httpd/apache.conf b/t/lib-httpd/apache.conf
index 7d15e6d44c83..f667e7ce2f33 100644
--- a/t/lib-httpd/apache.conf
+++ b/t/lib-httpd/apache.conf
@@ -64,6 +64,9 @@ LockFile accept.lock
<IfModule !mod_mpm_prefork.c>
LoadModule mpm_prefork_module modules/mod_mpm_prefork.so
</IfModule>
+<IfModule !mod_unixd.c>
+ LoadModule unixd_module modules/mod_unixd.so
+</IfModule>
</IfVersion>
PassEnv GIT_VALGRIND
--
2.7.1.429.g45cd78e