larsxschneider@gmail.com writes:
From: Lars Schneider <redacted>
diff to v5:
* rename 'type' to 'origin_type' as 'type' is too broad a word in the context
of configuration file (Thanks to the reviewers Junio and Dscho)
* add dedicated patch to rename git_config_from_buf to git_config_from_mem
(this change was part of the series since v4 as suggested by Junio but
hidden in the "config: add 'origin_type'" patch)
Thanks,
Lars
Overall this round looks good.
I personally prefer 'stdin' to be spelled out as '(the) standard
input' in end-user facing messages, e.g. the expected message in
this piece
test_expect_success 'invalid stdin config' '
echo "fatal: bad config line 1 in stdin " >expect &&
to say "line 1 in the standard input", but that is a quite minor
point and just a preference.
Thanks.
Let's queue this version and move it forward to 'next' soonish.