On Mon, Feb 15, 2016 at 1:18 PM, Jeff King [off-list ref] wrote:
This is definitely an improvement, but I think we can actually go a step
further here, and use parse_config_key. Like:
- if (starts_with(key, "branch.")) {
- name = key + 7;
- subkey = strrchr(name, '.');
- if (!subkey)
+ if (starts_with(key, "branch", &name, &namelen, &subkey)) {
I guess you meant: s/starts_with/parse_config_key/
quoted hunk ↗ jump to hunk
+ if (!name)
return 0;
- branch = make_branch(name, subkey - name);
+ branch = make_branch(name, namelen);
if (!strcmp(subkey, ".remote")) {
return git_config_string(&branch->remote_name, key, value);
} else if (!strcmp(subkey, ".pushremote")) {