Thread (10 messages) flat view 10 messages, 2 authors, 2016-06-15

Re: [PATCH 1/6] shortlog: match both "Author:" and "author" on stdin

From: Junio C Hamano <hidden>
Date: 2016-06-15 23:07:48

Possibly related (same subject, not in this thread)

Jeff King [off-list ref] writes:
So it's not wrong, but it's perhaps more complicated than it needs to
be. We could scrap this patch in favor of just:

  if (!skip_prefix(author, "Author: ", &v) &&
      !skip_prefix(author, "author ", &v))
          continue;

That is technically more strict (it does not take "author: ", which is
accepted by the current code), but matches "git log" and "git log --raw"
output, and misses nothing that git has ever generated. And it extends
naturally to:

  if (!skip_prefix(author, "Commit: ", &v) &&
      !skip_prefix(author, "committer ", &v))
          continue;
Yeah, I agree that the above long-hand would be more readable.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help