Re: [PATCH 01/10] t9100-git-svn-basic.sh: use the $( ... ) construct for command substitution
From: Junio C Hamano <hidden>
Date: 2016-06-15 23:07:43
Elia Pinto [off-list ref] writes:
quoted hunk
@@ -265,18 +265,18 @@ test_expect_success 'able to dcommit to a subdirectory' " git update-index --add d && git commit -m '/bar/d should be in the log' && git svn dcommit -i bar && - test -z \"\`git diff refs/heads/my-bar refs/remotes/bar\`\" && + test -z \"\$(git diff refs/heads/my-bar refs/remotes/bar)\" &&
This is entirely outside the scope of this series, but we may want to see if it makes it easier to read and maintain to turn executable part of test_expect_success that is double-quoted to use single quotes around it instead for many of our tests. This one is a prime example of it. I do not think the executable part is getting _any_ benefit from being quoted inside double-quote pair. All the single quoted strings it uses in the script commands (e.g. the argument to "git commit -m") can equally be quoted with double quotes safely, and there is no $variable reference that it wants to refer to the value of the $variable when the command line of test_expect_success itself is constructed.
quoted hunk
mkdir newdir && echo new > newdir/dir && git update-index --add newdir/dir && git commit -m 'add a new directory' && git svn dcommit -i bar && - test -z \"\`git diff refs/heads/my-bar refs/remotes/bar\`\" && + test -z \"\$(git diff refs/heads/my-bar refs/remotes/bar)\" && echo foo >> newdir/dir && git update-index newdir/dir && git commit -m 'modify a file in new directory' && git svn dcommit -i bar && - test -z \"\`git diff refs/heads/my-bar refs/remotes/bar\`\" + test -z \"\$(git diff refs/heads/my-bar refs/remotes/bar)\" " test_expect_success 'dcommit should not fail with a touched file' '@@ -295,7 +295,7 @@ test_expect_success 'able to set-tree to a subdirectory' " git update-index d && git commit -m 'update /bar/d' && git svn set-tree -i bar HEAD && - test -z \"\`git diff refs/heads/my-bar refs/remotes/bar\`\" + test -z \"\$(git diff refs/heads/my-bar refs/remotes/bar)\" "
Likewise.