On 01/05/2016 07:03 PM, Junio C Hamano wrote:
David Turner [off-list ref] writes:
quoted
I'm working on the rest now, but wanted to comment on this first. I
went ahead and made this change, but I'm not sure I like it. In the
git codebase, the concept will continue to be called "backend"; there
are already-accepted patches using that terminology. Having two
separate names for the same thing seems confusing to me.
We have the option to update whatever "are already-accepted" [*1*].
That would allow us to uniformly call it "ref storage", if we wanted
to.
...whereas whatever we name the option, we have to live with forever
because it is user-facing. It's more important to get the option name
correct (though I agree that it would be nice for the nomenclature used
in the code to be reminiscent of the option name).
Michael
--
Michael Haggerty
mhagger@alum.mit.edu