On Mon, Aug 10, 2015 at 4:27 PM, Jeff King [off-list ref] wrote:
The problem is that git_path uses a static buffer that gets overwritten
by subsequent calls.
resolve_ref() was in the same boat, then we renamed it to
resolve_ref_unsafe(), I believe with an intention to eventually kill
it. But it lives on anyway. I wanted to suggest renaming git_path() to
git_path_unsafe(). But I'm not sure if that will catch reviewer's eyes
when new call sites are added. Probably not..
--
Duy