Thread (12 messages) flat view 12 messages, 1 author, 2016-06-15
DORMANTno replies

Revision v6 of 7 in this series.

Revisions (7)
  1. v2 [diff vs current]
  2. v3 [diff vs current]
  3. v4 [diff vs current]
  4. v5 [diff vs current]
  5. v6 current
  6. v7 [diff vs current]
  7. v8 [diff vs current]

[PATCH v6 00/11] add options to for-each-ref

From: Karthik Nayak <hidden>
Date: 2016-06-15 23:05:31

v5 of this patch series can be found here :
http://article.gmane.org/gmane.comp.version-control.git/272590

This is a continuation of my GSoC project to unify git tag -l, git
branch -l and for-each-ref. Continued from this patch series :
http://thread.gmane.org/gmane.comp.version-control.git/271563

Changes in v5:
03/11: grammatical changes.
04/11: grammatical changes.
05/11: remove unnecessary if statement and remove caps used in commit message.
06/11: use xcalloc instead of using a commit_list as we know the size
of the array.
07/11: s/<object>/[<object>]/ as the object is optional.
08/11: rename parse_opt_commit_object_name() to parse_opt_commits().
09/11: make branch.c also to use the macros.
11/11: s/<object>/[<object>]/ as the object is optional.

Changes in v6:
Renamed the test file from t6301 to t6302 to avoid conflicts.

Thanks to Matthieu, Christian, Junio and Eric for the input on the
last iteration.

--
Regards,
Karthik Nayak
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help