On Tue, Jun 16, 2015 at 12:43 PM, Jeff King [off-list ref] wrote:
On Tue, Jun 16, 2015 at 09:39:19AM -0700, Junio C Hamano wrote:
quoted
As to the documentation, I have a feeling that, unless the reader
and/or the user intimately knows that TRACE_PACK is implemented by
hooking into the same mechanism that TRACE_PACKET needs to, s/he
would not even wonder if TRACE_PACKET needs to be enabled when
asking for TRACE_PACK. Yes, one is a proper substring of the other,
but the similarity between the two stops there. While I do not
think it would hurt very much to mention that they are independent,
I have a slight suspicion that it might make it more likely to get
user confused.
Yes, I was just re-reading the documentation based on Augie's comment,
and it seems pretty clear to me. Of course I wrote it, so that is not
saying much. Augie, I'd be happy to hear a proposed wording change if
you have one.
Yeah, I don't have one - I may have been making assumptions because I
knew something of the background on your implementation. i'd say let
it live and if people provide feedback later figure out a reword
(writing for humans is not a strong suit of mine, alas.)
I do kind of hate the name TRACE_PACK for two reasons:
- it _is_ so close to TRACE_PACKET; maybe TRACE_PACKFILE would be
better
+1 on TRACE_PACKFILE - also makes it harder to accidentally leave off
the ET and get binary spew when one didn't expect that.
AF