On Sun, Jun 14, 2015 at 1:21 PM, erik elfström [off-list ref] wrote:
On Sun, Jun 14, 2015 at 5:42 AM, Eric Sunshine [off-list ref] wrote:
quoted
This variable name doesn't convey much about its purpose, and
introduces a bit of maintenance burden if the limit is some day
changed. Perhaps "sane_size_limit" or something even more descriptive
(and/or terse) would be better.
Would you be happy with this change?
- static const int one_MB = 1 << 20;
+ static const int max_file_size = 1 << 20; /* 1MB */
Yep, that's a much nicer variable name. Thanks.
I also note that 'const int' shows up pretty frequently in the git
source code, but 'static const int' is used only very rarely.