Thread (8 messages) 8 messages, 4 authors, 2016-06-15

Re: [PATCH 0/3] Another approach to large transactions

From: Stefan Beller <hidden>
Date: 2016-06-15 23:04:30

Possibly related (same subject, not in this thread)

On Tue, Apr 21, 2015 at 4:21 PM, Jeff King [off-list ref] wrote:
On Mon, Apr 20, 2015 at 05:31:11PM -0700, Stefan Beller wrote:
quoted
When running the test locally, i.e. not in the test suite, but typing
the commands
myself into the shell, Git is fine with having just 5 file descriptors left.
The additional 4 required fds come from beign run inside the test suite.

When strace-ing git, I cannot see any possible other fds which would require
having some left over space required. So I'd propose we'd just take a reasonable
number not too small for various test setups like 32 and then go with the
proposed patches.
FWIW, we already use a magic value of "25 extra" in open_packed_git_1. I
don't know if that means the number has been proven in practice, or if
it is simply that nobody actually exercises the pack_max_fds code. I
suspect it is the latter, especially since d131b7a (sha1_file.c: Don't
retain open fds on small packs, 2011-03-02).
25 is equally sound as I could not find any hard calculation on that
number in the
history or code. I will change it to 25 in the next version of the patch.

Thanks!
Stefan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help