On Thu, Feb 12, 2015 at 3:12 AM, Michael Haggerty [off-list ref] wrote:
- int flags; /* REF_NODEREF? */
- int have_old; /* 1 if old_sha1 is valid, 0 otherwise */
+ /*
+ * One or more of REF_HAVE_OLD, REF_NODEREF,
+ * REF_DELETING, and REF_IS_PRUNING:
+ */
+ int flags;
Nit:
I'd find it more readable if it would be:
/*
* One or more of
* REF_HAVE_OLD,
* REF_NODEREF,
* REF_DELETING,
* REF_IS_PRUNING:
* whose definition is found at the top of this file.
*/
With or without the nit:
Reviewed-by: Stefan Beller <redacted>