Thread (2 messages) flat view 2 messages, 2 authors, 2016-06-15

Re: [PATCH] move MAXDEPTH definition to the cache.h

From: Torsten Bögershausen <hidden>
Date: 2016-06-15 23:03:37

quoted hunk ↗ jump to hunk
--- a/cache.h
+++ b/cache.h
@@ -1010,6 +1010,7 @@ extern int read_ref(const char *refname, unsigned char *sha1);
  * Caps and underscores refers to the special refs, such as HEAD,
  * FETCH_HEAD and friends, that all live outside of the refs/ directory.
  */
What happened to the comment line ?
Should it go away or better stay ?

When we move the definition to a common file,
it is not 100% clear what MAXDEPTH is about,
and the comment is even more important, I think:
+/* We allow "recursive" symbolic links. Only within reason, though. */
+#define MAXDEPTH 5
On the other hand, if we find a better name for that definition,
we may skip the comment.

A first suggestion may be
#define MAXDEPTH_FOR_SYMLINKS 5
but other variants are possible.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help