Eric Sunshine [off-list ref] writes:
quoted
+--atomic::
+ Use the an atomic transaction on the server side if available.
s/the an/an/
...
quoted
+ OPT_BIT(0, "atomic", &flags, N_("use a single atomic transaction at the serverside, if available"),
"single atomic" sounds awfully redundant.
"serverside" is odd. Perhaps "server side" or merely "remote" or "remote side".
...
quoted
diff --git a/transport.h b/transport.h
index 3e0091e..25fa1da 100644
--- a/transport.h
+++ b/transport.h
@@ -125,6 +125,7 @@ struct transport {
#define TRANSPORT_PUSH_NO_HOOK 512
#define TRANSPORT_PUSH_FOLLOW_TAGS 1024
#define TRANSPORT_PUSH_CERT 2048
+#define TRANSPORT_ATOMIC_PUSH 4096
For consistency with existing names, should this be TRANSPORT_PUSH_ATOMIC?
As always, thanks for a careful reading. I missed everything you
pointed out (I agree with you).