Re: [PATCH v2 0/7] repack_without_refs(): convert to string_list
From: Stefan Beller <hidden>
Date: 2016-06-15 23:03:07
On Tue, Nov 25, 2014 at 12:02 AM, Michael Haggerty [off-list ref] wrote:
This is a re-roll of v1 [1] with the following changes: * Fix some nits in the commit message and comment change in patch 4/7 that were pointed out by Jonathan. * Add a new patch 7/7 that renames sort_string_list() to string_list_sort() as suggested by Junio. I would have submitted the name change as a separate patch, but since this patch series uses the function the two series would have conflicted. Since I didn't see any other patch series in-flight that use sort_string_list(), I just renamed the function everywhere rather than going to the trouble of deprecating the old function and adding the new function. Thanks to Junio, Jonathan, and Stefan for their reviews of v1.
This series is also Reviewed-By: Stefan Beller <redacted> As this is in conflict with origin/sb/simplify-repack-without-refs we'd need to decide, which we'd take. I'd gladly go with this series as it seems cleaner and easier to read.
[1] http://thread.gmane.org/gmane.comp.version-control.git/259831/focus=260030 Michael Haggerty (7): prune_remote(): exit early if there are no stale references prune_remote(): initialize both delete_refs lists in a single loop prune_remote(): sort delete_refs_list references en masse repack_without_refs(): make the refnames argument a string_list prune_remote(): rename local variable prune_remote(): iterate using for_each_string_list_item() Rename sort_string_list() to string_list_sort() Documentation/technical/api-string-list.txt | 4 +- builtin/apply.c | 2 +- builtin/receive-pack.c | 2 +- builtin/remote.c | 69 +++++++++++++---------------- builtin/repack.c | 2 +- connect.c | 2 +- notes.c | 2 +- refs.c | 38 ++++++++-------- refs.h | 10 ++++- remote.c | 6 +-- sha1_file.c | 2 +- string-list.c | 4 +- string-list.h | 2 +- 13 files changed, 75 insertions(+), 70 deletions(-) -- 2.1.3