Re: [PATCH 22/32] checkout: support checking out into a new working directory
From: Duy Nguyen <hidden>
Date: 2016-06-15 23:02:26
On Wed, Sep 3, 2014 at 12:33 AM, Junio C Hamano [off-list ref] wrote:
Marc Branchaud [off-list ref] writes:quoted
On 14-09-02 08:27 AM, Duy Nguyen wrote:quoted
After reading this "multiple checkout mode" in git-checkout.txt, I'm tempted to rewrite it like this. I think the example makes it clearer what I mean. If nobody has any comments, I'm going to send v2 with this (and other comments collected so far)Overall I think focusing on the word "checkout" for this feature makes the documentation confusing. It's also not a "mode" but just another git feature. Since this is all about multiple working directories (the phrase is actually "working tree" in the existing docs) we should just stick to that rather than introduce new terminology. Finally, a bit of bikeshedding, but I think "$GIT_DIR/repos" is also an unfortunate choice and that "$GIT_DIR/worktrees" would be better.I tried to stay away from bikeshedding, but a good phrasing is important. I think $GIT_DIR/worktrees captures what they are trying to represent better in that they are not storing repository information, but they are about storing per-worktree state.
Good thing this topic is in pu. Will s/repos/worktrees/ then.
quoted
So I suggest the following for the new section:
Will replace my text with yours. Thanks. -- Duy