Duy Nguyen [off-list ref] writes:
On Thu, Jul 31, 2014 at 1:03 AM, Junio C Hamano [off-list ref] wrote:
quoted
Michael J Gruber [off-list ref] writes:
quoted
As an error message that is completely sufficient.
The advice messages are meant to teach the user about the normal parts
of the toolchest to use in a situation of "conflict", aren't they?
Not really. They are to remind (to those who learned but forgot)
and to hint (to those who haven't realized they have things to learn
in this area). Wall of text that tries to do more than that, like
"teaching", risks not getting read by anybody.
Last call to all. Keep this 'advice' or drop it?
I think you quoted what I needed to say already so I won't repeat
myself. Earlier you said:
If you have two checkouts associated to the same repo, "git
checkout foo" on one checkout when "foo" is held by another
checkout would cause the same error. I'll need to think of a
better name than advice.checkoutTo.
and I agree; the patch needs rerolling in any case.