On Thu, Jun 12, 2014 at 02:39:00PM -0500, Caleb Thompson wrote:
Use write_script from t/test-lib-functions.sh instead of cat, shebang,
and chmod. This protects us from potential shell meta-characters in the
name of our trash directory, which would be interpreted if we set
$EDITOR directly.
I'm not sure about this last sentence; isn't that what test_set_editor
is doing, which was already there? I think the real rationale is
readability: since $SHELL_PATH is handled for us, you can turn off
interpolation in the here-doc containing the helper script. That avoids
an extra layer of quoting.
-Peff