Re: [PATCH] Rewrite diff-no-index.c:read_directory() to use is_dot_or_dotdot() and rename it to read_dir()
From: Akshay Aurora <hidden>
Date: 2016-06-15 23:00:19
Forgot to mention, this is one of the microprojects for GSoC this year. Would be great to have some feedback. On Fri, Mar 14, 2014 at 6:09 PM, Akshay Aurora [off-list ref] wrote:
quoted hunk
I have renamed diff-no-index.c:read_directory() to read_dir() to avoid name collision with dir.c:read_directory() Signed-off-by: Akshay Aurora <redacted> --- diff-no-index.c | 9 +++++---- 1 file changed, 5 insertions(+), 4 deletions(-)diff --git a/diff-no-index.c b/diff-no-index.c index 8e10bff..2a17c9f 100644 --- a/diff-no-index.c +++ b/diff-no-index.c@@ -10,13 +10,14 @@ #include "blob.h" #include "tag.h" #include "diff.h" +#include "dir.h" #include "diffcore.h" #include "revision.h" #include "log-tree.h" #include "builtin.h" #include "string-list.h" -static int read_directory(const char *path, struct string_list *list) +static int read_dir(const char *path, struct string_list *list) { DIR *dir; struct dirent *e;@@ -25,7 +26,7 @@ static int read_directory(const char *path, struct string_list *list) return error("Could not open directory %s", path); while ((e = readdir(dir))) - if (strcmp(".", e->d_name) && strcmp("..", e->d_name)) + if (!is_dot_or_dotdot(e->d_name)) string_list_insert(list, e->d_name); closedir(dir);@@ -107,9 +108,9 @@ static int queue_diff(struct diff_options *o, int i1, i2, ret = 0; size_t len1 = 0, len2 = 0; - if (name1 && read_directory(name1, &p1)) + if (name1 && read_dir(name1, &p1)) return -1; - if (name2 && read_directory(name2, &p2)) { + if (name2 && read_dir(name2, &p2)) { string_list_clear(&p1, 0); return -1; } --1.8.5.3
-- With Thanks & Warm Regards Akshay Aurora iakshay.net