Andrew Wong [off-list ref] writes:
On Wed, Feb 26, 2014 at 3:38 PM, Jonathan Nieder [off-list ref] wrote:
quoted
Andrew Wong wrote:
quoted
--- a/builtin/merge.c
+++ b/builtin/merge.c
@@ -909,7 +909,8 @@ static int suggest_conflicts(int renormalizing)
+ "fix conflicts and then commit the result.\n"
+ "To abort the merge, use \"git merge --abort\".\n"));
[...]
This means contexts are no longer only about "resolving conflict", so
I was thinking of renaming advice.resolveConflict to something like
advice.mergeHints.
Any thoughts?
If the advice suggests merge --abort, then why not advice.abortMerge ?
But mergeHints makes sense to me also, as it would potentially encompass
more cases.
--
Matthieu Moy
http://www-verimag.imag.fr/~moy/