Jeff King [off-list ref] writes:
I'm happy with it either way. I almost just pulled the macro
definitions, including DIFF_FILE_VALID, out of the struct definition
completely. I see the value in having the flags near their bitfield, but
it makes the definition a bit harder to read.
Yeah, my thoughts exactly when I did those two conflicting changes.
I have a slight preference "Constants go with the fields they are
used in" over "fields and macros mixed together is harder to read",
so let's use your patch as-is.