Thread (4 messages) flat view 4 messages, 3 authors, 2016-06-15

Re: [PATCH v4 1/6] submodule: Make 'checkout' update_module explicit

From: W. Trevor King <hidden>
Date: 2016-06-15 22:59:40

On Thu, Jan 16, 2014 at 09:07:22PM +0100, Francesco Pretto wrote:
2014/1/16 W. Trevor King [off-list ref]:
quoted
Avoiding useless clones is probably more important than avoiding
duplicate "Invalid update mode" messages.
No, it's not duplicate code.
I meant “duplicating the "Invalid update mode" error message”.  I
missed the die-early distinction, but I understand now.  I think its
non-DRY to have an early case statement to validate the update_module,
and a later case statement to use it.  Still, keeping those separate
statements in sync shouldn't be too hard ;).
Please keep both as Junio said.
That's what I said I'd do in the email you're quoting ;).  Are you ok
with the die-early validation checking all update_module settings
instead of just checking the loaded-from config branch?

Cheers,
Trevor

-- 
This email may be signed or encrypted with GnuPG (http://www.gnupg.org).
For more information, see http://en.wikipedia.org/wiki/Pretty_Good_Privacy

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help