On Thu, Dec 5, 2013 at 2:23 AM, Junio C Hamano [off-list ref] wrote:
* cc/starts-n-ends-with (2013-12-04) 4 commits
- replace {pre,suf}fixcmp() with {starts,ends}_with()
- strbuf: introduce starts_with() and ends_with()
- builtin/remote: remove postfixcmp() and use suffixcmp() instead
- environment: normalize use of prefixcmp() by removing " != 0"
(this branch is used by cc/starts-n-ends-with-endgame.)
Remove a few duplicate implementations of prefix/suffix comparison
functions, and rename them to starts_with and ends_with.
This conflicts with a part of cc/remote-remove-redundant-postfixcmp
topic (I think it actually subsumes it).
Yeah, it subsumes it.
Thanks,
Christian.