Thread (3 messages) flat view 3 messages, 3 authors, 2016-06-15

Re: [PATCH v4 0/5] Disable "git status" comment prefix

From: Jeff King <hidden>
Date: 2016-06-15 22:58:39

On Thu, Sep 05, 2013 at 09:36:47PM +0200, Matthieu Moy wrote:
Junio C Hamano [off-list ref] writes:
quoted
One caveat, though.  The name "oldStyle" will become problematic,
when we want to remove some wart in the output format long after
this "no comment prefix by default" series lands.  Some people may
expect setting oldStyle=true would give output from 1.8.4 era, while
some others would expect that it would give output from 1.8.5 era
that does not have comment prefix but still has that wart we will
remove down the line.
I'm fine with any name actually (since it is enabled by default, people
don't need to know the name to benefit from the new output). Maybe
status.displayCommentPrefix was the best name after all.
FWIW, I had the same thought as Junio. I much prefer something like
status.displayCommentPrefix for clarity and future-proofing.

As for the feature itself, I am still undecided whether I like it. I've
tried looking at the output of the series, and it feels weird to me.

Part of it is undoubtedly that my brain is simply used to the other way.
But it also seems to drop some of the vertical whitespace, which makes
things feel very crowded. E.g., before:

  # On branch private
  # Your branch and 'origin/next' have diverged,
  # and have 472 and 59 different commits each, respectively.
  #
  # Untracked files:
  #       t/foo
  #       test-obj-pool
  #       test-string-pool
  #       test-treap
  #       test-url-normalize
  nothing added to commit but untracked files present

after:

  On branch private
  Your branch and 'origin/next' have diverged,
  and have 472 and 59 different commits each, respectively.
  Untracked files:
          t/foo
          test-obj-pool
          test-string-pool
          test-treap
          test-url-normalize
  nothing added to commit but untracked files present

The blank before "Untracked files" was dropped (was this intentional? I
didn't see any note of it in the discussion), and the bottom "nothing
added" line butts against the untracked list more obviously, because
they now all have the same comment indentation.

I wonder if it would look a little nicer as:

  On branch private
  Your branch and 'origin/next' have diverged,
  and have 472 and 59 different commits each, respectively.

  Untracked files:
          t/foo
          test-obj-pool
          test-string-pool
          test-treap
          test-url-normalize

  nothing added to commit but untracked files present

As an orthogonal thing to your patch, I feel like the first two items
(branch and ahead/behind) are kind of squished and oddly formatted (in
both the original and yours). Could we do something like:

  Your branch 'private' and its upstream 'origin/next' have diverged,
  and have 472 and 59 different commits each, respectively.

when we are going to print both?  That's 69 characters, which might
overrun 80 if you have long branch names, but we could also line-break
it differently.

That doesn't need to be part of your topic, but while we are talking
about the format of the message, maybe it is worth thinking about.

-Peff
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help