Eric Sunshine wrote:
On Sun, Aug 25, 2013 at 1:55 AM, Jonathan Nieder [off-list ref] wrote:
quoted
Would be clearer if the code in a subshell were indented:
(
unset test_tick &&
test_commit ...
)
I considered it, but decided against it for a couple reasons:
* In this script, there already is a mix between the two styles:
indented vs. unindented.
* In this particular patch, the test_commit line creating commit3
wrapped beyond 80 columns when indented.
I'm just one person, but I find the indented form way more readable.
Long lines or lines with \ continuation are not a big deal.
[...]
Should this be worth a re-roll?
Since the file already has a mixture of styles, if there's no other
reason to reroll, I'd suggest leaving it alone.
The next time it bugs me or someone else, that person can write a
patch that cleans up the whole file on top. :)
Thanks,
Jonathan