There are configuration options for each submodule that specify under what
circumstances git status should display output for that submodule.
Unfortunately, these settings were not being respected, and as such the tests
were marked TODO.
This patch series consists of two patches: the first is a fix for a confusing
variable name, and the latter actually makes git status not output the submodule
information. The tests have been updated accordingly.
Changes from v1:
* Handle moved submodules by not ignoring them.
* Use sm_path instead of path.
* Only ignore when --for-status is given.
brian m. carlson (2):
submodule: fix confusing variable name
submodule: don't print status output with ignore=all
git-submodule.sh | 15 +++++++++++----
t/t7508-status.sh | 4 ++--
2 files changed, 13 insertions(+), 6 deletions(-)
--
1.8.4.rc2.564.g10ce5ae