Re: [PATCH] gitweb: allow extra breadcrumbs to prefix the trail
From: Jakub Narębski <hidden>
Date: 2016-06-15 22:58:00
On Thu, Jul 4, 2013 at 10:44 AM, Tony Finch [off-list ref] wrote:
Jakub Narębski [off-list ref] wrote:quoted
On Wed, Jul 3, 2013 at 11:59 PM, Jonathan Nieder [off-list ref] wrote:quoted
Tony Finch wrote:quoted
quoted
+@extra_breadcrumbs::
BTW. perhaps (it is only an idea) @top_level_breadcrumbs or @home_breadcrumbs would be a better name for this variable.
quoted
quoted
quoted
+ Additional links to be added to the start of the breadcrumb trail, + that are logically "above" the gitweb projects list. For example, + links to the organization and department which host the gitweb + server. Each element of the list is a reference to an array, + in which element 0 is the link text and element 1 is the + target URL.Is arbitrary HTML permitted in the link text?I had the same question when I was wondering about abusing $home_link_str to do this without a patch :-)
Not exactly arbitrary, as it is inside A element, so it cannot contain A links itself (hyperlinks should not be nested), but it is not esc_html-aped.
quoted
quoted
I think it makes sense to permit it for consistency with $home_link_str, but it might be worth mentioning in the manpage so the administrator knows not to set it to something user-controlled --- e.g.:I left this detail out of the man page for consistency with the documentation for $home_link_str.
It would be better to improve documentation, than follow current bad practice... ;-P
quoted
Nb. it would be nice to have relation of @extra_breadcrumbs with $home_link_str explained.I will make that clearer.
Perhaps even make ( [ $home_link_str, $home_link ] ) to be default value for @extra_breadcrumbs, making new feature generalization of $home_link*, similarly to how it was done for $stylesheet -> @stylesheets transition. What do you think about it? -- Jakub Narębski