On Tue, Feb 26, 2013 at 02:12:23PM -0800, Junio C Hamano wrote:
Heiko Voigt [off-list ref] writes:
quoted
The "do_config_from" means "parse from whatever is in 'top'". Later in
the series its type changes from config_file to struct config.
Yuck. It would be nice to have it as struct config_src or
something. "struct config" sounds as if it represents the entire
configuration state and you can ask it to add new ones or enumerate
all known configuration variables, etc.
Will change it to struct config_source. I choose that name in lack of a
better one. Since it can be considered the base for both sources I just
removed the _file postfix.
Cheers Heiko