Thread (1 message) 1 message, 1 author, 2016-06-15

Re: [PATCH] git-send-email: add ~/.authinfo parsing

From: Matthieu Moy <hidden>
Date: 2016-06-15 22:56:04

Ted Zlatanov [off-list ref] writes:
Logically they are different steps (query and response), even though the
data protocol is the same.  But it's really not a big deal, I know what
it means either way.
Yes, but if you rename write() to query(), then on the helper side,
you'll have to call query() to send the response, and response() to read
the query. Much worse than keeping read/write.

Plus, read/write has already been used for a while in the C API, so I'd
rather keep the same names for the Perl equivalent.

-- 
Matthieu Moy
http://www-verimag.imag.fr/~moy/
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help