Thread (3 messages) flat view 3 messages, 2 authors, 2016-06-15

Re: [PATCH v2 2/2] i18n: mark OPTION_NUMBER (-NUM) for translation

From: Jiang Xin <hidden>
Date: 2016-06-15 22:56:04

Possibly related (same subject, not in this thread)

2013/2/6 Junio C Hamano [off-list ref]:
I somehow suspect that this is going in a direction that makes this
piece of code much less maintainable.

Look at the entire function and see how many places you do fprintf
on strings that are marked with _().  short_name and long_name are
not likely to be translated, but everything else is, especially
multiple places that show _(opts->help) neither of these patches
touch.

I wonder if it makes more sense to add a helper function that
returns the number of column positions (not bytes) with a signature
similar to fprintf() and use that throughout the function instead.
I agree, a helper named 'utf8_fprintf' in utf8.c is better.
I will send a patch latter.


-- 
Jiang Xin
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help