Re: [PATCH 2/4] mergetool--lib: Improve the help text in guess_merge_tool()
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:55:55
David Aguilar [off-list ref] writes:
quoted hunk
This code path is only activated when the user does not have a valid configured tool. Add a message to guide new users towards configuring a default tool. Signed-off-by: David Aguilar <redacted> --- git-mergetool--lib.sh | 9 ++++++++- 1 file changed, 8 insertions(+), 1 deletion(-)diff --git a/git-mergetool--lib.sh b/git-mergetool--lib.sh index 9a5aae9..cf52423 100644 --- a/git-mergetool--lib.sh +++ b/git-mergetool--lib.sh@@ -240,7 +240,14 @@ show_tool_help () { guess_merge_tool () { list_merge_tool_candidates - echo >&2 "merge tool candidates: $tools" + msg="\ + +This message is displayed because '$TOOL_MODE.tool' is not configured. +See 'git ${TOOL_MODE}tool --tool-help' or 'git help config' for more details. +'git ${TOOL_MODE}tool' will now attempt to use one of the following tools: +$tools +" + printf "$msg" >&2
This is not wrong per-se, but wouldn't it be much easier to read to
use an indented HERE-text like this?
cat >&2 <<-EOF
... a long message with $var substitution ...
... comes here ...
EOF