Thread (1 message) 1 message, 1 author, 2016-06-15

Re: [PATCH] git-remote: distinguish between default and configured URLs

From: Junio C Hamano <hidden>
Date: 2016-06-15 22:55:47

Michael J Gruber [off-list ref] writes:
In short, the separate listing is correct, but in this case there's no
improvement in readability.
Yes, I think the "insteadOf" rewrite is a related but a separate
issue.

Is "remote -v" meant for diagnosing remote.origin.{url,pushurl} that
are misconfigured?

If not, the output just should just say the final outcome, i.e. what
destinations we will fetch from and push to, without cluttering the
output.

If on the other hand it is to help users debug their configuration,
the output also needs to explain exactly what made us decide those
destinations to use (e.g. to discover there was a leftover insteadof
in $HOME/.gitconfig the user forgot about).
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help