On Fri, Jan 11, 2013 at 06:20:57PM +0700, Nguyễn Thái Ngọc Duy wrote:
+#define PATHSPEC_FROMTOP (1<<0)
The previous commit introduces a use of this macro in get_pathspec.
Should this be defined by that commit instead?
quoted hunk ↗ jump to hunk
@@ -266,9 +266,9 @@ static int pathspec_item_cmp(const void *a_, const void *b_)
* Given command line arguments and a prefix, convert the input to
* pathspec. die() if any magic other than ones in magic_mask.
*/
-static void parse_pathspec(struct pathspec *pathspec,
- unsigned magic_mask, unsigned flags,
- const char *prefix, const char **argv)
+void parse_pathspec(struct pathspec *pathspec,
+ unsigned magic_mask, unsigned flags,
The prototype for this function uses just "magic" instead of
"magic_mask". Should they be consistent?
--
Matt