Re: [PATCH] gitk: read and write a repository specific configuration file
From: Lukasz Stelmach <hidden>
Date: 2016-06-15 22:55:29
W dniu 09.12.2012 11:44, Paul Mackerras pisze:
On Sun, Dec 09, 2012 at 01:18:08AM -0800, Junio C Hamano wrote:quoted
Łukasz Stelmach [off-list ref] writes:quoted
Enable gitk read and write repository specific configuration file: ".git/k" if the file exists. To make gitk use the local file simply create one, e.g. with the touch(1) command. This is very useful if one uses different views for different repositories. Now there is no need to store all of them in ~/.gitk and make the views list needlessly long.I do not use gitk heavily myself, but I have a mixed feeling about this patch.I agree, I think this would be surprising to people who are used to the way gitk works now. I could imagine having a checkbox in the Edit->Preferences dialog to say "Save configuration settings locally", and if you check that box, then it writes the configuration to .git/gitkconfig or whatever (having first saved that setting in the global ~/.gitk).
No this isn't a good idea. When you choose to save configuration locally it means you've alredy changed it to match your local needs and making it global does not seem reasonable.
But I think it should be an opt-in thing.
It is opt-in now definitely. One needs to create the local config file, even an empty one, for gitk to choose it upon doquit/savestuff. I agree a checkbox may be more convenient but is it "opty" (as in opt-in) enough? Then, the checkbox should be added to both "Preferences" and "Edit View" dialogs, anything more?
quoted
In any case, the filename .git/k may be _cute_, but I do not think we would want to see: $ ls .git branches config HEAD index k objects COMMIT_EDITMSG description hooks info logs refs It is too cryptic, unless the user _knows_ 'k' is for gitk. I'd call it $GIT_DIR/gitkconfig or something, if I were supportive for this feature (which I am not enthusiastic, yet).I agree with this too.
Sure, let's vote: a) .git/gitk b) .git/gitkconfig c) .git/gitkrc -- Było mi bardzo miło. Czwarta pospolita klęska, [...]
Łukasz< Już nie katolicka lecz złodziejska. (c)PP