Added a new config option to turn off the already-exists advice. We
also want to observe the 'pushNonFastForward' setting, but the name of
this config is too narrow after this addition. Renamed to have broader
scope while retaining the old name as an alias for backward-
compatibility.
Chris Rorvick (2):
push: rename config variable for more general use
push: allow already-exists advice to be disabled
Documentation/config.txt | 10 +++++++---
advice.c | 9 +++++++--
advice.h | 3 ++-
builtin/push.c | 8 +++++---
4 files changed, 21 insertions(+), 9 deletions(-)
--
1.8.0.1.541.g73be2da