Nguyễn Thái Ngọc Duy [off-list ref] writes:
+ if (opts.patch_mode || opts.pathspec)
+ return cmd_checkout_entry(&opts, &new);
+ else
+ return cmd_switch(&opts, &new);
}
Yeah, patch_mode is really part of checking out paths, so separating
the actions into two makes sense.
Even though I am not sure about "cmd_" prefix (as these are not
commands), I'll rename the former "cmd_checkout_paths" to be
consistent with the underlying checkout_paths() function, and the.
latter "cmd_checkout_branch" for consistency with the former (you
either check out one-or-more paths, or check out a branch).