Re: [PATCH 04/17] Name local variables more consistently
From: Michael Haggerty <hidden>
Date: 2016-06-15 22:54:34
On 08/23/2012 10:39 AM, Jeff King wrote:
On Thu, Aug 23, 2012 at 10:10:29AM +0200, mhagger@alum.mit.edu wrote:quoted
From: Michael Haggerty <redacted> Use the names (nr_heads, heads) consistently across functions, instead of sometimes naming the same values (nr_match, match).I think this is fine, although:quoted
--- a/builtin/fetch-pack.c +++ b/builtin/fetch-pack.c@@ -521,7 +521,7 @@ static void mark_recent_complete_commits(unsigned long cutoff) } } -static void filter_refs(struct ref **refs, int nr_match, char **match) +static void filter_refs(struct ref **refs, int nr_heads, char **heads) { struct ref **return_refs; struct ref *newlist = NULL;@@ -530,12 +530,12 @@ static void filter_refs(struct ref **refs, int nr_match, char **match) struct ref *fastarray[32]; int match_pos;This match_pos is an index into the "match" array, which becomes "head". Should it become head_pos? And then bits like this:quoted
- while (match_pos < nr_match) { - cmp = strcmp(ref->name, match[match_pos]); + while (match_pos < nr_heads) { + cmp = strcmp(ref->name, heads[match_pos]);Would be: while (head_pos < nr_heads) which makes more sense to me.
I was up in the air about this, because match_pos *is* the position at which a match is attempted. But since the name also strikes you as wrong, I will change it in the next version. Thanks for this and all of your other comments! Michael -- Michael Haggerty mhagger@alum.mit.edu http://softwareswirl.blogspot.com/