"Joachim Schmitz" [off-list ref] writes:
I thought of having the function decclaration in git-compat-util.h, just
like for eg. setenv, gitmkdtemp, etc.
Yeah, that's also fine, especially if you do not have to declare
structures and constants.
Once you start having to declare other things in order to declare
the function missing on the system, it won't be like setenv where a
pair of #ifdef NO_SETENV/#endif just surrounds a single line. At
that point, a separate header file to hold them together would
become easier to read. It's a judgement call; we'll see how it
turns out (we do not have to get everything right in our first
attempt).