Re: [PATCH v4 03/18] sha1_name.c: get rid of ugly get_sha1_with_mode_1()
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:54:12
Matthieu Moy [off-list ref] writes:
Junio C Hamano [off-list ref] writes:quoted
+/* + * Call this function when you know "name" given by the end user must + * name an object but it doesn't; the function _may_ die with a better + * diagnostic message than "no such object 'name'", e.g. "Path 'doc' does not + * exist in 'HEAD'" when given "HEAD:doc", or it may return in which case + * you have a chance to diagnose the error further. + */ +void die_on_misspelt_object_name(const char *name, const char *prefix)It seems unusual to have a function named die_* that is not a noreturn function. I'd call it die_*_maybe, or diagnose_* instead. (but as the comment above documents the behavior, it's not terribly important, you may ignore my comment if you whish)
I was hoping "on" may imply "if not misspelled, ignore and keep going", but apparently that failed. I am not good at names. die_if_misspelt? maybe_die_on_misspelt? I am fairly negative on "diagnose" as it does not say much about what would happen after diagnosis (namely, we _die_).