Matthieu Moy [off-list ref] writes:
My version reads as
try something;
if (it failed && I'm only here to report an error)
report_error();
which I find easier to understand.
I agree that _this_ part is easy to understand when written that
way. But then shouldn't there be a blanket "The caller is here only
to report an error, but all the previous code didn't find any error,
so there is something wrong" check much later in the code before it
returns a success? Or am I being too paranoid?