Thread (1 message) 1 message, 1 author, 2016-06-15

Re: [PATCHv2 1/2] git-remote-mediawiki: import "File:" attachments

From: Matthieu Moy <hidden>
Date: 2016-06-15 22:54:02

Pavel Volek [off-list ref] writes:
+		# Get pages of related media files.
+		if ($import_media) {
+			get_mw_pages_for_linked_mediafiles(\@tracked_pages, \%pages);
+		}
The comment is useless given the function name.
+# Returns MediaWiki id for a canonical namespace name.
+# Ex.: "File", "Project".
+# Looks for the namespace id in the local configuration
+# variables, if it is not found asks MW API.
Functions are usually specified in imperative form, hence "Return", not
"Returns" for example.
+	my $file = $mediawiki->download( { title => $filename } );
I'd call that $file_content, to avoid confusion with the file name.

Other than that, the patch looks good (but I didn't review very
carefully).

-- 
Matthieu Moy
http://www-verimag.imag.fr/~moy/
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help