Thread (1 message) 1 message, 1 author, 2016-06-15

Re: git rebase -f --autosquash

From: Junio C Hamano <hidden>
Date: 2016-06-15 22:53:59

Phil Hord [off-list ref] writes:
...  That both are
required seems to me to be an embarrassing, historical implementation
detail.
I do not know if we are discussing the same thing.

There is nothing historical in that "--interactive" is the word used
to tell the command that the user wants to replay commits in an
order that is different from the order they were found in the
original commit DAG.  If you want to tweak the order, you use
"interactive". If you don't, you don't.

There indeed is implementation detail to worry about. The "-p" mode
that is *not* about letting the user modify the order of replayed
commits internally does use the same machinery as interactive, but
that is hidden from the end user (the "implied" value in
$interactive_rebase in git-rebase.sh makes this difference).

But this case is not about replaying the commit without reordering.

If you are proposing to rename "--interactive" to "--reorder" or
something, with a solid migration plan to keep the current users
happy, and possibly are proposing to add non-interactive autosquash
implementation outside git-rebase--interactive.sh, the issue would
entirely be different, but I somehow do not sense that is the
direction in which you are trying to go.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help